import re
regex = re.compile(r"\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(\")[^\"\\]*(?:\\.[^\"\\]*)*\"|(')[^'\\]*(?:\\.[^'\\]*)*')")
test_str = ("Test\n"
"a=\"abc\";\n"
"b='def';\n"
"c=\"That's the way to do it\";\n"
"d='That\\'s the way \"to do it\"';\n"
"e=e.replace(//g, '\"');\n"
"f=f.replace(/'/g, '\"');\n"
"g=g.replace(/\\'/g, '\"');\n"
"h=h.replace(/\\\"/g, '\\\"');\n"
"i=i.replace(/\\\\\"/g, '\\\\\"');\n")
subst = "$1XXXX$1"
result = regex.sub(subst, test_str)
if result:
print(result)