#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')"
Local $sString = "Test" & @CRLF & _
"a="abc";" & @CRLF & _
"b='def';" & @CRLF & _
"c="That's the way to do it";" & @CRLF & _
"d='That\'s the way "to do it"';" & @CRLF & _
"e=e.replace(//g, '"');" & @CRLF & _
"f=f.replace(/'/g, '"');" & @CRLF & _
"g=g.replace(/\'/g, '"');" & @CRLF & _
"h=h.replace(/\"/g, '\"');" & @CRLF & _
"i=i.replace(/\\"/g, '\\"');" & @CRLF & _
""
Local $sSubst = "$1XXXX$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)