const regex = new RegExp('\\(\\s*/.*?/\\w*\\h*,(*SKIP)(*F)|(?|(")[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|(\\')[^\\'\\\\]*(?:\\\\.[^\\'\\\\]*)*\\')', 'g')
const str = `Test
a="abc";
b='def';
c="That's the way to do it";
d='That\\'s the way "to do it"';
e=e.replace(//g, '"');
f=f.replace(/'/g, '"');
g=g.replace(/\\'/g, '"');
h=h.replace(/\\"/g, '\\"');
i=i.replace(/\\\\"/g, '\\\\"');
`;
const subst = `$1XXXX$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);