import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\s*/.*?/\\w*\\h*,(*SKIP)(*F)|(?|(\")[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"|(')[^'\\\\]*(?:\\\\.[^'\\\\]*)*')";
final String string = "Test\n"
+ "a=\"abc\";\n"
+ "b='def';\n"
+ "c=\"That's the way to do it\";\n"
+ "d='That\\'s the way \"to do it\"';\n"
+ "e=e.replace(//g, '\"');\n"
+ "f=f.replace(/'/g, '\"');\n"
+ "g=g.replace(/\\'/g, '\"');\n"
+ "h=h.replace(/\\\"/g, '\\\"');\n"
+ "i=i.replace(/\\\\\"/g, '\\\\\"');\n";
final String subst = "$1XXXX$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}