package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')`)
var str = `Test
a="abc";
b='def';
c="That's the way to do it";
d='That\'s the way "to do it"';
e=e.replace(//g, '"');
f=f.replace(/'/g, '"');
g=g.replace(/\'/g, '"');
h=h.replace(/\"/g, '\"');
i=i.replace(/\\"/g, '\\"');
`
var substitution = "$1XXXX$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}