// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')"#).unwrap();
let string = "Test
a=\"abc\";
b='def';
c=\"That's the way to do it\";
d='That\\'s the way \"to do it\"';
e=e.replace(//g, '\"');
f=f.replace(/'/g, '\"');
g=g.replace(/\\'/g, '\"');
h=h.replace(/\\\"/g, '\\\"');
i=i.replace(/\\\\\"/g, '\\\\\"');
";
let substitution = "$1XXXX$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}