use strict;
my $str = 'Test
a="abc";
b=\'def\';
c="That\'s the way to do it";
d=\'That\\\'s the way "to do it"\';
e=e.replace(//g, \'"\');
f=f.replace(/\'/g, \'"\');
g=g.replace(/\\\'/g, \'"\');
h=h.replace(/\\"/g, \'\\"\');
i=i.replace(/\\\\"/g, \'\\\\"\');
';
my $regex = qr~\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')~p;
my $subst = '$1XXXX$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";