using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|("")[^""\\]*(?:\\.[^""\\]*)*""|(')[^'\\]*(?:\\.[^'\\]*)*')";
string substitution = @"$1XXXX$1";
string input = @"Test
a=""abc"";
b='def';
c=""That's the way to do it"";
d='That\'s the way ""to do it""';
e=e.replace(//g, '""');
f=f.replace(/'/g, '""');
g=g.replace(/\'/g, '""');
h=h.replace(/\""/g, '\""');
i=i.replace(/\\""/g, '\\""');
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}