# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bdog[^\w\n]+\b//gmi;t' <<< "The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog"