re = /\bdog[^\w\n]+\b/mi
str = 'The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result