$re = '/\bdog[^\w\n]+\b/mi';
$str = 'The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;