const regex = /\bdog[^\w\n]+\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdog[^\\w\\n]+\\b', 'gmi')
const str = `The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);