import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bdog[^\\w\\n]+\\b";
final String string = "The quick brown fox jumps over the lazy dog\n"
+ "The dog was lazy\n"
+ "The dog dog dog \n"
+ "The dog dog \n"
+ "The dog";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}