// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\bdog[^\w\n]+\b").unwrap();
let string = "The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}