#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\bdog[^\w\n]+\b"
Local $sString = "The quick brown fox jumps over the lazy dog" & @CRLF & _
"The dog was lazy" & @CRLF & _
"The dog dog dog " & @CRLF & _
"The dog dog " & @CRLF & _
"The dog"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)