package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bdog[^\w\n]+\b`)
var str = `The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}