use strict;
my $str = 'The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog';
my $regex = qr/\bdog[^\w\n]+\b/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";