import Foundation
let pattern = #"\bdog[^\w\n]+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)