using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdog[^\w\n]+\b";
string substitution = @"";
string input = @"The quick brown fox jumps over the lazy dog
The dog was lazy
The dog dog dog
The dog dog
The dog";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}