# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:([^1])(\d+\.))/\n$2/g;t' <<< "1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd"