import re
regex = re.compile(r"(?:([^1])(\d+\.))")
test_str = "1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd"
subst = "\\n$2"
result = regex.sub(subst, test_str)
if result:
print(result)