#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:([^1])(\d+\.))"
Local $sString = "1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd"
Local $sSubst = "\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)