use strict;
my $str = '1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd';
my $regex = qr/(?:([^1])(\d+\.))/p;
my $subst = '\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";