$re = '/(?:([^1])(\d+\.))/';
$str = '1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd';
$subst = "\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;