// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:([^1])(\d+\.))").unwrap();
let string = "1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd";
let substitution = "\\n$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}