re = /(?:([^1])(\d+\.))/
str = '1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd'
subst = '\\n$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result