import Foundation
let pattern = #"(?:([^1])(\d+\.))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)