using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([^1])(\d+\.))";
string substitution = @"\n$2";
string input = @"1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}