# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^proc _*(.*?)_*\*/proc $1*/gm;t' <<< "proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard"