#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^proc _*(.*?)_*\*"
Local $sString = "proc foo*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc foo_*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc foo__*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc __foo*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc __foo__*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc foo_bar_*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc foo_bar*() =" & @CRLF & _
" discard" & @CRLF & _
"" & @CRLF & _
"proc _foo_bar_*() =" & @CRLF & _
" discard"
Local $sSubst = "proc $1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)