re = /^proc _*(.*?)_*\*/m
str = 'proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard'
subst = 'proc $1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result