package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^proc _*(.*?)_*\*`)
var str = `proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard`
var substitution = "proc $1*"
fmt.Println(re.ReplaceAllString(str, substitution))
}