using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^proc _*(.*?)_*\*";
string substitution = @"proc $1*";
string input = @"proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}