const regex = /^proc _*(.*?)_*\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^proc _*(.*?)_*\\*', 'gm')
const str = `proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard`;
const subst = `proc $1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);