use strict;
my $str = 'proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard';
my $regex = qr/^proc _*(.*?)_*\*/mp;
my $subst = 'proc $1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";