import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^proc _*(.*?)_*\\*";
final String string = "proc foo*() =\n"
+ " discard\n\n"
+ "proc foo_*() =\n"
+ " discard\n\n"
+ "proc foo__*() =\n"
+ " discard\n\n"
+ "proc __foo*() =\n"
+ " discard\n\n"
+ "proc __foo__*() =\n"
+ " discard\n\n"
+ "proc foo_bar_*() =\n"
+ " discard\n\n"
+ "proc foo_bar*() =\n"
+ " discard\n\n"
+ "proc _foo_bar_*() =\n"
+ " discard";
final String subst = "proc $1*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}