import re
regex = re.compile(r"^proc _*(.*?)_*\*", flags=re.MULTILINE)
test_str = ("proc foo*() =\n"
" discard\n\n"
"proc foo_*() =\n"
" discard\n\n"
"proc foo__*() =\n"
" discard\n\n"
"proc __foo*() =\n"
" discard\n\n"
"proc __foo__*() =\n"
" discard\n\n"
"proc foo_bar_*() =\n"
" discard\n\n"
"proc foo_bar*() =\n"
" discard\n\n"
"proc _foo_bar_*() =\n"
" discard")
subst = "proc $1*"
result = regex.sub(subst, test_str)
if result:
print(result)