$re = '/^proc _*(.*?)_*\*/m';
$str = 'proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard';
$subst = "proc $1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;