#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$"
Local $sString = "'''" & @CRLF & _
"MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS: " & @CRLF & _
"ADD MISSING OPENING AND/OR CLOSING DELIMITER" & @CRLF & _
"(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)" & @CRLF & _
"sad" & @CRLF & _
"fsd" & @CRLF & _
"f" & @CRLF & _
"sdasdf" & @CRLF & _
"dsf" & @CRLF & _
"'''"
Local $sSubst = "'''\n$1\n'''"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)