$re = '/^(?:\'\'\'\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?\'\'\'\n?)?$/';
$str = '\'\'\'
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
\'\'\'';
$subst = "'''\n$1\n'''";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;