const regex = /^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\'\'\'\\n?)?((?:.*?)(?:\\n.*?)*?)(?:\\n?\'\'\'\\n?)?$', 'g')
const str = `'''
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
'''`;
const subst = `'''\n$1\n'''`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);