import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:'''\\n?)?((?:.*?)(?:\\n.*?)*?)(?:\\n?'''\\n?)?$";
final String string = "'''\n"
+ "MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS: \n"
+ "ADD MISSING OPENING AND/OR CLOSING DELIMITER\n"
+ "(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)\n"
+ "sad\n"
+ "fsd\n"
+ "f\n"
+ "sdasdf\n"
+ "dsf\n"
+ "'''";
final String subst = "'''\\n$1\\n'''";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}