// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$").unwrap();
let string = "'''
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
'''";
let substitution = "'''\\n$1\\n'''";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}