import Foundation
let pattern = #"^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'''
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
'''
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'''\n$1\n'''"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)