using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$";
string substitution = @"'''\n$1\n'''";
string input = @"'''
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
'''";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}