package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$`)
var str = `'''
MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS:
ADD MISSING OPENING AND/OR CLOSING DELIMITER
(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)
sad
fsd
f
sdasdf
dsf
'''`
var substitution = "'''\n$1\n'''"
fmt.Println(re.ReplaceAllString(str, substitution))
}