# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:'''\n?)?((?:.*?)(?:\n.*?)*?)(?:\n?'''\n?)?$"
test_str = ("'''\n"
"MATCH THE TEXT WITH ZERO, ONE OR NO DELIMITERS: \n"
"ADD MISSING OPENING AND/OR CLOSING DELIMITER\n"
"(NOTE: ALSO MATCHES WITH BOTH DELIMITERS)\n"
"sad\n"
"fsd\n"
"f\n"
"sdasdf\n"
"dsf\n"
"'''")
subst = "'''\\n$1\\n'''"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.