using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)";
string substitution = @"$1 <span class=""time"">$2</span> $3<span class=""time"">$4</span>$5";
string input = @"Lorem 1:06:16 ips48:5um.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}