import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)\\s+(\\d+:\\d+:\\d+)\\s+(.+?)(\\d+:\\d+)(\\S+)";
final String string = "Lorem 1:06:16 ips48:5um.";
final String subst = "$1 <span class=\"time\">$2</span> $3<span class=\"time\">$4</span>$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}