re = /(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)/m
str = 'Lorem 1:06:16 ips48:5um.'
subst = '$1 <span class="time">$2</span> $3<span class="time">$4</span>$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result